Skip to Main Content
Spotfire Ideas Portal
ADD A NEW IDEA

Ideas

Allow Admins to post in-tool messages to all connected clients.

To provide better user engagement and more efficient use of resources, especially in light of dynamically scaling down the number of active Spotfire servers in a cloud configuration, Spotfire Admins should be able to broadcast important messages t...
over 9 years ago in Spotfire / System Administration 0 Future Consideration

please add "Reset" button to the "Table Settings" dialog in order to reset all changes for a specific table

please add "Reset" button to the "Table Settings" dialog in order to reset all changes for a specific table. Currently one can only clear browser's cache to reset all tables' settings. "Table Settings" dialog is added by below new feature: SPOT-16...
11 months ago in Spotfire / System Administration 0 Future Consideration

Support dynamic secrets for connecting to data sources

Our security policy requires that all databases (specifically those on the public cloud) use dynamic secrets (rather than static credentials). Dynamic secrets are well suited to processes (e.g., Java, node.js, etc.) that are built using a pipeline...
over 7 years ago in Spotfire Data Virtualization / data sources 0 Future Consideration

Spotfire Server Database - Set a value for all entries in the table LICENSE_FUNCTIONS

Having a field called 'LICENSE_FUNCTION_DISPLAY_NAME' with empty values does not help to get the accuracy required when it comes to creating reporting on Spotfire instances. See attached screenshot. Thank you for your consideration. Kind regards, ...
over 4 years ago in Spotfire / System Administration 1 Will not implement

Allow the view Definitions to be published along with the view

Users are not able to see the view definitions of the views that they connect to through the Data Virtualization tool. View definitions are required for QA teams and other users to validate that the view is bringing back the correct information.
over 7 years ago in Spotfire Data Virtualization / data movement 0 Future Consideration

Improved LDAP error logging

When LDAP search is run, to verify a logging in user, and the server returns logs a warning like "Error performing an LDAP search", the search should also be logged, so the reason for the errors can be investigated properly. Not know why LDAP retu...
almost 3 years ago in Spotfire / System Administration 0 Future Consideration

TDV Procedure to return dynamic result set as output based on input

Hi, My idea is based on following support request. https://support.tibco.com/s/case/5004z00001uHJYhAAO/dynamic-cursors-in-tdv-procedures One of our client want to fetch different result sets from a TDV procedure based on the input passed to it. Cu...
almost 3 years ago in Spotfire Data Virtualization / data movement 0 Likely to implement

change Exception error message from login module

Hello. My idea was written based on the following SR. https://support.tibco.com/s/case/5004z00001sr0n9AAA/how-to-change-error-message-from-login-module In data virtualization, the Login Module is available, which can cause LoginException....
almost 3 years ago in Spotfire Data Virtualization / access control 0 Likely to implement

Disable Schedule for Scheduling & Routing Files

In "Scheduling & Routing" currently you can disable rules for files, which turns off the routing of users to a cached copy of the file. However, when troubleshooting issues with a data source, it would be helpful to be able to quickly disable ...
over 5 years ago in Spotfire / Scheduled Updates 0 Future Consideration

Ability to download cs_server.log file from DV Manager

Often times I work as an administrator on a DV server hosted on infrastructure I don't have access to. For troubleshooting purposes it would be very useful to be able to download the cs_server.log file from the DV Manager web interface. This allow...
12 months ago in Spotfire Data Virtualization / monitoring 0 Future Consideration