Skip to Main Content
Spotfire Ideas Portal
ADD A NEW IDEA

Ideas

Add connection type LDAP+StartTLS for Spotfire Server connection to LDAP.

Currently Spotfire Server can connect to OpenLDAP via LDAP and LDAPS. The preferred way of connection for OpenLDAP is LDAP+StartTLS, which is not provided as connection type at the moment. Our current approach is making only use of LDAP+StartTLS a...
almost 9 years ago in Spotfire / System Administration 2 Future Consideration

Limit number of visualizations a user can have open at one time

There are cases where a user will attempt to open what is deemed an excessive number of visualizations (or even multiple instances of the same visualization). The cause of this is irrelevant (could be bad programming on a publicly viewed client, o...
almost 9 years ago in Spotfire / System Administration 0 Future Consideration

show process id for each WP/AS instance in Monitoring&Diagnostics page

In order to diagnose WP issue sometimes we need to collect memory dump (https://support.tibco.com/s/article/Tibco-KnowledgeArticle-Article-45793), however it's kinda difficult to know the instance's process id especially when there are many instan...
over 4 years ago in Spotfire / System Administration 0 Future Consideration

schedule web player/automation services service/instance restart from spotfire server

Customer encountered an issue that web player/automation services consume too much memory/temporary disk space, by restarting web player/automation services service/instance the issue was resolved so they hope spotfire server can provide a functio...
about 9 years ago in Spotfire / System Administration 0 Future Consideration

log detail message for ClientError

Sometimes, log like below is outputed in the server.log of Spotfire Server, that is all the information that is logged and no detail message is shown. ERROR 2021-11-16T14:15:00,799+0900 [guest8@ANONYMOUS, #B-7, #18] wp.controller.ErrorPageControll...
over 4 years ago in Spotfire / System Administration 0 Future Consideration

Specific role or licence for "Nodes & Services" option

To have a specific role or a specific licence to control access for "Nodes & Services" option. This idea is similar https://ideas.tibco.com/ideas/TS-I-5549 but it talks about read only access. In my case I need to allow access an user to this ...
about 9 years ago in Spotfire / System Administration 0 Future Consideration

Please revive the error stack in the web player

Somewhere along the recent 7.x versions, the stack trace disappeared along with the error icon in the web player. In practice, this has been a useful and helpful feature - the user can just send the stack trace along to support and troubleshooting...
about 9 years ago in Spotfire / System Administration 0 Future Consideration

Allocate custom Log path for Node server and spotfire server

Hi Tibco, Please allocate custom Log path for Node server and spotfire server as it is deflate to make manage monitoring on each service logs for different versions as log path keep on changing for upgrade, So please focus log paths can be defined...
over 4 years ago in Spotfire / System Administration 1 Already exists

Geographically dispersed Spotfire Nodes and Servers in a single collective

The idea here is that by supporting geographically dispersed collectives we can gain several improvements: Ability to process data near the data source (e.g. if we have a large database in Europe and others in US it would be advantageous to proce...
over 9 years ago in Spotfire / System Administration 1 Future Consideration

allow to show keywords, description etc in file's property dialog in OS's Explorer

Customer expect spotfire to allow to show keywords, description etc in file's property dialog in OS's Explorer. In order to quickly check some information stored inside the dxp file, without opening it in Analyst. They have many versions(for busin...
over 4 years ago in Spotfire / System Administration 1 Already exists